My server works, but it won't show on the list!

All multiplayer related discussion.

Moderator: Forum Guards

My server works, but it won't show on the list!

Postby Nightcaper » Mon Sep 22, 14 4:11 pm

I've had a frustrating 2 days trying to set up my server. The server is a rental from GamingDeluxe with cpanel. It came pre-configured with MTL and miniMTL, and I put on a new map and such, as well as changed the master server uplink to master.deusexnetwork.com. I cannot find it in the list, even after much tweaking and filing a support ticket, they told me to ask someone on the master server side for help:


Image



So now I am here, and I want to settle this issue, once and for all. I can directly connect to the server, without issue, but it will not show up in the query whatsoever. Here is the basic network information for the server itself:


Image



Here are all the relevant sections of my deusex.ini on the server:

Code: Select all
[DeusEx.DeusExGameEngine]
CacheSizeMegs=4
UseSound=True
ServerActors=IpDrv.UdpBeacon
ServerActors=IpServer.UdpServerQuery
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master0.gamespy.com MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.epicgames.com MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.fragaholic.com MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.deusexnetwork.com MasterServerPort=27900

ServerPackages=DXMTL152b1


[IpServer.UdpServerQuery]
GameName=deusex



[IpDrv.UdpBeacon]
DoBeacon=True
BeaconTime=0.50
BeaconTimeout=5.0
BeaconPort=7776
BeaconProduct=DeusEx



[DeusEx.MenuScreenJoinGame]
MasterServerAddress=master.deusexnetwork.com


[Engine.GameReplicationInfo]
ServerName=Bartender's PartyTime Fun Maps (UNDER CONSTRUCTION)
;ShortName=Bartender's PartyTime Fun Maps (UNDER CONSTRUCTION)
;Admin=Bartender
;AdminEmail=nightcaper112@gmail.com
AdminName=Bartender
AdminEmail=nightcaper112@gmail.com
Region=0
;MOTDLine1=welcome on gamingdeluxe power server
;MOTDLine2=go to server console, preferences (right click on Deus Ex
;MOTDLine3=icon in down right corner of your screen in Windows) and
;MOTDLine4=



[IpServer.UdpBeacon]
BeaconProduct=DeusEx



[QValidateLoader103.QLoader]
bQValidateInstalled=true




I've tried multiple things, I even tried changing BeaconPort in IpDrv.UdpBeacon to the Query port stated in the server information. The server still will not show. I can provide more information if necessary, but please help me fix this. This server wasn't cheap, and I really want to at least get my money's worth out of it. Is the master server receiving anything from it? Is there a way for someone at DXA to check that?
Nightcaper
Newbie
 
Posts: 8
Joined: Thu Sep 18, 14 6:17 pm

Re: My server works, but it won't show on the list!

Postby Nightcaper » Mon Sep 22, 14 4:29 pm

Update: Help is no longer necessary. GamingDeluxe, turns out, does not have their server produce the section called "IpServer.UdpServerUplink" by default. I got the section from my .ini after hosting a LAN, added it and made modifications, and it's showing up perfectly now. Sorry for the disturbance.
Nightcaper
Newbie
 
Posts: 8
Joined: Thu Sep 18, 14 6:17 pm


Return to Multiplayer

Who is online

Users browsing this forum: Bing [Bot] and 7 guests