How Come My Server Does Not Show??!!?

Technical issues discussion about your computer and Deus Ex games.

Moderator: Forum Guards

How Come My Server Does Not Show??!!?

Postby Billmaster » Sun Sep 30, 12 8:34 pm

It even says resolved on the console but I can only see it in lan.

"Nephthys: 2012/09/30 15:12:27: NptServerUplink: Port 14881 successfully bound for master server master0.gamespy.com:27900 "

Thank in advance,
Adult[Z]wim
Attachments
DeusEx.ini
(16.47 KiB) Downloaded 156 times
Billmaster
Newbie
 
Posts: 45
Joined: Thu Dec 22, 05 3:52 am

Postby Kaiden » Sun Sep 30, 12 9:26 pm

http://www.dxalpha.com/forum/viewtopic.php?t=5782

Threads pretty old but the info is still relevant, make sure to go through that, namely ports.
------
Kaiden
Alpha
 
Posts: 6985
Joined: Wed Jan 18, 06 11:21 pm
Location: England

Postby Billmaster » Sun Sep 30, 12 10:09 pm

I opened every port and disable every firewall I give up deus ex fuck you old ass game.
Billmaster
Newbie
 
Posts: 45
Joined: Thu Dec 22, 05 3:52 am

Postby Kaiden » Sun Sep 30, 12 11:33 pm

Although with that said, when I hosted it'd appear in LAN even though it was online, and it does for others too. The best way to test it would be to host it and test if anyone else can see it on the server list.
Last edited by Kaiden on Sun Sep 30, 12 11:33 pm, edited 1 time in total.
------
Kaiden
Alpha
 
Posts: 6985
Joined: Wed Jan 18, 06 11:21 pm
Location: England

Postby Poor » Mon Oct 01, 12 12:08 am

Yeah, this drove me nuts too but I eventually got it.

From an older post I made:

Even if the firewall is disabled, you still need to give Deus Ex permission to communicate. It's weird but that's how Windows works.

But first, you should check if your ports are forwarded correctly. Use this program to check the ports 7790, 7791, and 7792 using UDP.
http://portforward.com/help/portcheck.htm

After you confirmed the ports are forwarded, try this:

Go to start menu, type "firewall", and choose "Windows Firewall with Advanced Security". Create a new inbound rule for the program deusex.exe. Then create a new outbound rule for deusex.exe.

Then type firewall in the start menu again. Choose "Allow a program though Windows Firewall". Make sure Deus Ex is checked and make sure the two checkboxes next to it are checked.
Poor
Poster
 
Posts: 190
Joined: Tue Jan 04, 11 7:42 pm

Postby Billmaster » Mon Oct 01, 12 2:45 am

yup just did all that poor and it still not show.
Billmaster
Newbie
 
Posts: 45
Joined: Thu Dec 22, 05 3:52 am

Postby Kalman11 » Mon Oct 01, 12 5:40 am

Do you have router? If yes, disable it's firewall or enable DMZ
Last edited by Kalman11 on Mon Oct 01, 12 5:41 am, edited 1 time in total.
Kalman11
Wannabe
 
Posts: 122
Joined: Tue Aug 03, 10 2:38 pm
Location: 9th circle of hell

Postby ~DJ~ » Mon Oct 01, 12 10:20 am

errr.. well I'm no expert, but this sounds off.. open your DeusEx.ini and find:
[IpServer.UdpServerUplink]

at this, you see 'MasterServerPort=14879'

scrap that and make it:

Code: Select all
MasterServerPort=27900


..also make sure that DoUplink is true.. it's one of the options located just there.
User avatar
~DJ~
Forum Super Hero
 
Posts: 3765
Joined: Tue May 22, 07 12:23 pm

Postby Billmaster » Sun Oct 14, 12 12:10 am

well that messed it up worse lol
Billmaster
Newbie
 
Posts: 45
Joined: Thu Dec 22, 05 3:52 am

Postby Aidan » Mon Oct 15, 12 7:12 pm

Do you keep your windows installation clean?

Any junkware on your PC?
User avatar
Aidan
CandyMan
 
Posts: 6265
Joined: Wed Aug 02, 06 8:57 am
Location: The Great White North


Return to Technical issues

Who is online

Users browsing this forum: No registered users and 2 guests
cron